Flex Fuel Issues

Post Reply
Posts: 21
Joined: Thu Nov 08, 2018 1:00 am

Flex Fuel Issues

Post by myblackhatch »

Hey Everyone,
Working with a 2005 RSX Base Ktuner R1 Board. OEM GM Continental Flex Fuel Sensors

My problem is I cannot get my ecu to pickup any reading from my flex fuel sensor.

I have a flex fuel sensor located by the gas tank and have it run inside to my ecu. It is powered by the 12v Pin87 of the main relay. It is currently grounded to the ktuner board where flex fuel is located and I get nothing.

I emailed Ktuner who explained that it is probably a ground issue. OK so here is what I have tried.

I ground the sensor to the chassis. Nothing
I connected the G on the board and the flex fuel sensor ground to a location on the chassis. Nothing
I have completely disconnected the sensor and connected it to another car battery. Power and ground on the battery.
I also added anther ground from that same setup to the sensor grounds on my valve cover. Nothing

I tested the sensor with my picoscope and got a 1v ish oscillation (I am on pump gas currently)

I swapped out my sensor with another flex fuel sensor and still have nothing.
I went and got e85 and dumped a sensor in it. Nothing
I switched the map to multiple different maps to see if it was maybe a software issue. Nothing

I have tried alot more combinations than this but for the sake of time I am sure we all get the point.
I have yet to get a single reading for ethanol content or have the flex fuel tables turn green.

I do get a small hit for flex frequency which usually drops back down to zero.

Just looking for some help with getting this figured out
Post Reply

Return to “General Hardware Questions”