Funky WOT TPS Readings

Civic/Integra/etc with a K swap

Funky WOT TPS Readings

Postby mattj » Wed Jun 06, 2018 1:19 pm

My K24 uses a Skunk2 intake with a 74mm B-series throttle body using an adapter. The reasoning for using the B-series was to get away from the K series TPS which seem to fail often in road race cars. That being said, when I purchased a TPS, I made sure not to buy a cheap POS. But who knows, it's still an aftermarket TPS.

I set the idle TPS voltage to 0.455 volts and that seems to work well. The problem is WOT, however, where the percentage in KTuner goes to 85% then immediately down to 23%. It's only the very last bit of throttle movement where it drops back to 23%.

Is this a sign of a lousy TPS? Should I try to get a used OEM one? Or maybe normal operation?

Thanks.
mattj
 
Posts: 7
Joined: Mon Apr 16, 2018 1:13 pm

Re: Funky WOT TPS Readings

Postby KTuner » Wed Jun 06, 2018 7:05 pm

If it's hitting 85% that's fine, but if it's not holding it that tells me the voltage is either dropping or has gone beyond the allowable voltage range. Does the CEL come on?
KTuner
Site Admin
 
Posts: 1186
Joined: Mon Jul 22, 2013 8:13 pm

Re: Funky WOT TPS Readings

Postby mattj » Wed Jun 06, 2018 7:12 pm

CEL does go on when the pedal is fully depressed and I get a TPS voltage error. I'm considering getting an OEM sensor but they are all pretty old at this point.
mattj
 
Posts: 7
Joined: Mon Apr 16, 2018 1:13 pm

Re: Funky WOT TPS Readings

Postby KTuner » Wed Jun 06, 2018 7:47 pm

It is overshooting the max voltage allowable, sounds like. If you bring down the idle voltage a bit it may allow WOT without coding.
KTuner
Site Admin
 
Posts: 1186
Joined: Mon Jul 22, 2013 8:13 pm

Re: Funky WOT TPS Readings

Postby mattj » Wed Jun 06, 2018 8:11 pm

That was my first try. It seems having the voltage lower at idle (I had it at .425V or so) it didn't seem like like it very well and it didn't fix the issue. I had a weird part throttle/cruise misfire or hesitation. Could be unrelated, but it seems to like .45V better.

Is it OK to have less than .45V at idle?

The car is going to Turbogixxer's shop next Wednesday so I'm trying to get the small bugs worked out before then.
mattj
 
Posts: 7
Joined: Mon Apr 16, 2018 1:13 pm

Re: Funky WOT TPS Readings

Postby KTuner » Wed Jun 06, 2018 8:22 pm

I'd get an Acuity TPS sensor if you can, otherwise go back to factory. The factory B series shouldn't span passed 4.5v and that shouldn't be throwing an error.
KTuner
Site Admin
 
Posts: 1186
Joined: Mon Jul 22, 2013 8:13 pm

Re: Funky WOT TPS Readings

Postby mattj » Wed Jun 06, 2018 8:35 pm

I'll do that and I'll check WOT voltage tonight and report back. Thank you.
mattj
 
Posts: 7
Joined: Mon Apr 16, 2018 1:13 pm

Re: Funky WOT TPS Readings

Postby KTuner » Wed Jun 06, 2018 9:58 pm

No problem
KTuner
Site Admin
 
Posts: 1186
Joined: Mon Jul 22, 2013 8:13 pm

Re: Funky WOT TPS Readings

Postby mattj » Thu Jun 14, 2018 12:32 pm

Quick update, a OEM TPS fixed my issue.
mattj
 
Posts: 7
Joined: Mon Apr 16, 2018 1:13 pm

Re: Funky WOT TPS Readings

Postby KTuner » Thu Jun 14, 2018 4:36 pm

mattj wrote:Quick update, a OEM TPS fixed my issue.


Glad to hear that!
KTuner
Site Admin
 
Posts: 1186
Joined: Mon Jul 22, 2013 8:13 pm


Return to K Swapped Vehicles

Who is online

Users browsing this forum: No registered users and 1 guest

cron